QtOctave 0.10.1 for Windows


Hi,

I’ve just finished the build for windows. Feel free to download it.

I recognized some problems on my Win XP machine and rebuild it. The link stays the same.

For the interested audience, I’ve uploaded my changes to the code.

  1. #1 von x am 04.02.2011 - 18:38:26

    w

  2. #2 von Richard am 07.02.2011 - 13:06:02

    Could you possibly post build instructions for windows? This would be a great help!

    Thanks

  3. #3 von PattiMichelle am 20.02.2011 - 04:36:54

    I love this software – I hope it can continue to grow and be maintained. I also hope for a 64-bit version for windows.

  4. #4 von Peter am 16.03.2011 - 15:14:16

    I’ve just installed Octave 3.2.4 and QtOctave 0.10.1 on Windows Vista.
    Using
    > plot(rand(10))
    gives a normal gnuplot in Octave, but in QtOctave I get
    >>>error: compare_versions: version numbers must be a single row
    error: called from:
    error: C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\miscellaneous\compare_v
    ersions.m at line 81, column 5
    error: C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\plot\__gnuplot_has_feat
    ure__.m at line 43, column 23
    error: C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\plot\gnuplot_drawnow.m
    at line 229, column 11
    error: C:\Octave\3.2.4_gcc-4.4.0\share\octave\3.2.4\m\plot\gnuplot_drawnow.m
    at line 97, column 16
    and there is an empty Easy Plot window.

    I have selected Use Easy Plot and put the correct path in the QtOctave config.
    What else do I need to change or configure?
    I tried the pkg rebuild -noauto oct2mat mentioned in the 0.9 thread, but oct2mat didn’t even exist.

    The rest is great, just would like to get the plotting to work!

  5. #5 von Elaina am 05.04.2011 - 23:46:28

    Uh. How do I actually install it? It doesn’t seem to work.

  6. #6 von Amar am 18.04.2011 - 20:39:14

    I have found a way to install it, if that helps anyone. Extract the downloaded zip file and then go to the share subfolder. Then go to qtoctave folder and copy the menus folder. Then go to C:\Users\your_name\.qtoctave and paste the previous folder. Go back to the original extracted folder. Then go to bin subfolder and double click on the qtoctave.exe. You must install octave (windows) before installing qtoctave. When the program start it will alert you that it did not find octave. Go to the general configuration in the configure menu of the program. Then go to the Octave tab and select the path of octave-version#.exe. Octave (windows) comes with notepad++ so if you want to use that the process is similar to the previous one. Restart qtoctave. Hope this helps.
    Cheers.

  7. #7 von LB am 20.04.2011 - 18:02:02

    Thank you for your efforts on this project, very nice. I did want to pass along some feedback regarding compatibility with the new release of Octave 3.2.4. 2D plot does not work properly. If and when you get a figure window to open, it is a not responding window. I tried the same with the earlier release of Octave 3.2.3 and it works properly.

  8. #8 von Geoffrey Pleiss am 27.04.2011 - 18:05:01

    I have been using QtOctave for a while now, and I’ve noticed that the run button in the editor mode doesn’t always work properly. Even after I save the script I’m working on multiple times, the run button will run an older version of the script.

  9. #9 von Kevin am 05.05.2011 - 20:36:20

    Thank you Amar, that worked perfectly!

  10. #10 von Laurent am 09.06.2011 - 18:02:29

    I got the same problem as Peter (16.03.2011) with the sombrero(50) Octave command, using QtOctave 0.10.1 and Octave-Forge 3.2.4; runs fine with Octave but goes into error with QtOctave.

  11. #11 von John am 13.07.2011 - 11:12:43

    nice job! it worked for me!

  12. #12 von jumko am 14.07.2011 - 14:26:14

    Hi. I have a problem. At the start QtOctave is opened on full screen but at the end of start script processing QtQctave window is reduced to very small rectangle. How I can remove this effect?

  13. #13 von Rhea am 19.08.2011 - 08:42:32

    Hi,
    I just tried to install qtoctave0.6.1 on my MacBookPro using the procedure explained by Javier Arántegui, but I block at step 6, because qmake does not create qtoctave.xcodeproj, but rather qtoctave.pro. And I can’t build that one with Xcode.

  14. #14 von bcn.jorge am 26.08.2011 - 12:40:00

    I have the same problem with PLOT..

    Is there any solution?

  15. #15 von Sferix am 12.10.2011 - 21:21:39

    I have qtoctave installed on a windows 7 starter machine. It has been working fine, but just yesterday there was a windows auto update from Microsoft and now qtoctave crashes when I run it. Anyone else seeing this ?

  16. #16 von Sferix am 15.10.2011 - 17:00:55

    Re #15 ‘qtoctave crashing after windows update’. Have applied service pack 1 for Win 7 and magically qtoctave has started working again. Seems service pack 1 fixes something the previous auto update broke.

  17. #17 von arturo am 20.10.2011 - 02:27:29

    thanks

  18. #18 von claire am 03.12.2011 - 23:32:08

    when i open qtoctave this error show up

    error: load: unable to find file C:/Users/Windows/.qtoctave/1322947051.varia
    bles

    what can i do?

  19. #19 von ucup am 18.12.2011 - 03:34:02

    claire, i got the same error, but nothing to be worried about, the program seems work well

  20. #20 von Jara am 07.02.2012 - 19:59:04

    Hello

    I have a problem with 2D plots. 2D plot does not work properly. If and when you get a figure window to open, it is a not responding window. What can I do?

    Thanks for Help

  21. #21 von Ubbi am 13.03.2012 - 10:43:33

    I’ve got the same problem with plots of #20..
    it seems not using easy plot or gnu plot even if I flag the box..

  22. #22 von MAJA am 19.03.2012 - 08:06:36

    cool

  23. #23 von Hasan am 12.06.2012 - 20:36:13

    Hello there,
    Is there any 64 bit version of qtoctave or still not doesnt exist yet ?
    thanks for any help…

  24. #24 von Hasan am 12.06.2012 - 20:37:19

    Hasan :
    Hello there,
    Is there any 64 bit version of qtoctave or still not doesnt exist yet ?
    thanks for any help…

  25. #25 von hanson am 03.07.2012 - 14:36:02

    I have the same problem of 2D plot like #21 #20.

  26. #26 von huliangbing am 10.10.2012 - 15:47:12

    gff

  27. #27 von pcboy am 24.10.2012 - 15:19:46

    x :
    w

    great job

  28. #28 von DonDortmund am 12.11.2012 - 15:58:20

    First of all: Great Work! Thanks a lot! Being used to Matlab, I find this GUI a superb option to continue my work on GNU basis!
    Apart from having the same plot problem reported by #21, #23, and #25 I found that my code – once called in the standart Octave environment – works out well.
    Here, you have to apply that
    pkg rebuild -noauto oct2mat
    workaround as described in e.g. http://octave.1599824.n4.nabble.com/Unresponsive-figure-windows-td2239680.html
    after having installed Octave and the Forge packages. Doing so, you have to run your code in the Octave enviroment, once you require a figure – a workaround, but at least it works.

    However, I am also lost on some more issues:
    a) the hung plot window in QToctave is still a mystery to me,
    b) the tiny window size reported by #12,
    c) the missing buttons, once you start a script via the right mouse menue (open with),
    d) the myriad of windows being opened behind the main editor window.

    I am using Win 7, SP 1, 64 Bit., Octave 3.6.2configured i686-pc-mingw32 along with QToctave 0.10.1.
    Thanks to anyone, who may share some hints on the issues mentioned above.
    Take care:
    Gerd

  29. #29 von Mamata am 25.02.2013 - 12:38:15

    I am using Octave 3.6.1
    pkg install “pkg name” command wont work for some package. Is there any other method to install package?

  30. #30 von mtk am 22.04.2013 - 06:10:10

    thank you very much

  31. #31 von Athira am 25.09.2013 - 04:32:57

    Great job, worked well for me too..!
    Also thank you Amar, it was a great help!

  32. #32 von armando am 30.11.2013 - 22:25:45

    i can’t create .qtoctave folder in windows7, so i got the

    >>>error: load: unable to find file C:/Users/ahlf/.qtoctave/1385842772.variable
    s

    how can i resolve that?

    thanks

    armando

  33. #33 von Anonymous am 14.12.2013 - 09:57:36

    Hasan :

    Hasan :
    Hello there,
    Is there any 64 bit version of qtoctave or still not doesnt exist yet ?
    thanks for any help…

    armando :
    i can’t create .qtoctave folder in windows7, so i got the
    >>>error: load: unable to find file C:/Users/ahlf/.qtoctave/1385842772.variable
    s
    how can i resolve that?
    thanks
    armando

    Hasan :

    Hasan :
    Hello there,
    Is there any 64 bit version of qtoctave or still not doesnt exist yet ?
    thanks for any help…

  34. #34 von Anonymous am 12.06.2014 - 19:13:36

    Richard :
    Could you possibly post build instructions for windows? This would be a great help!
    Thanks

  35. #35 von arbonne5 am 27.08.2014 - 20:17:25

    I had the same problem that plot commands would result in a non-responsive gnuplot window. The solution which worked for me was to add “-i –line-editing” as Octave arguments under Config–>General configuration–>Octave.
    There is only one side effect so far: IDE commands are now always shown in the octave terminal including sometimes control characters.

(wird nicht veröffentlicht)